Problem:
Po aktualizacji do wersji 2022 program zamyka się przy próbie wejścia do Pulpitu nieobecności.
Dotyczy baz, które w przeszłości pracowały jako wspólna baza z systemem ERP, modułem Handel.
Przyczyna:
Podczas konwersji do wersji 2022 nie dodaje się tabela [Common.UserSettings].
Rozwiązanie:
Modyfikacja z dnia 01.12.2021: Problem został już rozwiązany w wersji Symfonia ERP Kadry i Płace 2022.a
Rozwiązanie zostanie wbudowane do wersji 2022.a, która jest planowana na koniec listopada 2021.
Rozwiązanie dla wersji 2022: plik: Support_218844.dll
Sposób wczytania rozwiązania:
1. Przed wczytaniem rozwiązania proszę wykonać kopię bezpieczeństwa.
2. Przy zamkniętej aplikacji Symfonia ERP Kadry i Płace 2022 skopiować plik Support_218844.dll do katalogu z instalacją programu 2022 do katalogu Dodatki na jednym stanowisku, na którym rozwiązanie zostanie wczytane do bazy.
3. Zalogować się do bazy na użytkownika z prawami administratora.
4. Zaakceptować poniższy komunikat:
5. Po wykonaniu aktualizacji można już korzystać z pulpitu nieobecności.
Uwaga!
Z uwagi na zabezpieczenia systemowe czasami po pobraniu pliku z Internetu we właściwościach pliku może zostać zaznaczona opcja jako plik zewnętrzny.
Proszę sprawdzić czy w pobranym pliku o nazwie Support_218844.dll, który został dodany do katalogu z instalacją programu, we właściwościach pliku nie ma zaznaczonej opcji jako plik zewnętrzny albo Unblock.
Ten checkbox nie powinien być zaznaczony a może blokować wykonanie aktualizacji.
Może to wyglądać jak poniżej: