Problem:
Podczas uruchamiania aplikacji wyświetla się komunikat błędu Zdalny host zgłosił błąd: 'Brak połączenia z serwerem'.
Przyczyna:
Brak połączenia z usługą Symfonia Services.
Rozwiązanie:
I. Zweryfikuj na serwerze
Sprawdź działanie usługi Symfonia Services:
Krok 1. Kliknij prawym przyciskiem myszy na Menu Start i wybierz Menedżer zadań.
Krok 2. Przejdź do zakładki Usługi.
Krok 3. Na liście znajdź usługę o nazwie:
- Symfonia_SRV jeśli używasz programu Symfonia lub Symfonia ERP,
- Symfonia_KIP_SRV jeśli używasz programu Symfonia ERP Kadry i Płace.
W nazwie usługi znajduje się numer odpowiadającej wersji programu Symfonia.
Przykład – usługa dla programu Symfonia w wersji 2024
Krok 4. Sprawdź stan usługi w kolumnie Stan:
- Zatrzymana, kliknij na nazwę usługi prawym przyciskiem myszy. Z wyświetlonego menu wybierz opcję Uruchom.
- Uruchomiona, kliknij na nazwę usługi prawym przyciskiem myszy. Z wyświetlonego menu wybierz opcję Uruchom ponownie.
II. Zweryfikuj na stacji roboczej
Sprawdź ustawienia CMNConfig / CMNKIPConfig:
Krok 1. Kliknij prawym przyciskiem myszy na ikonie programu Symfonia.
Krok 2. Z rozwiniętego menu wybierz opcję Otwórz lokalizację pliku. Na ekranie wyświetli się okno z plikami programu.
Krok 3. Odszukaj i uruchom aplikację o nazwie:
- CMNConfig jeśli używasz programu Symfonia lub Symfonia ERP,
- CMNKIPConfig jeśli używasz programu Symfonia ERP Kadry i Płace.
Krok 4. Sprawdź konfigurację:
- w polu Parametry konfiguracji globalnej ustaw opcję Na serwerze,
- w polu Host wpisz nazwę serwera.
Krok 5. Naciśnij przycisk Testuj.
Krok 6. Po zakończonym teście wyświetli się jeden z dwóch komunikatów:
- „Testowanie zakończone powodzeniem” – naciśnij przycisk OK, następnie zatwierdź ustawienia klikając OK w oknie aplikacji CMNConfig lub CMNCKIPConfig. Możesz rozpocząć pracę w programie
-
„Zdalny host zgłosił błąd. Brak połączenia z serwerem” – naciśnij OK, dodaj port usługi Symfonia Services do wyjątków Zapory Windows za pomocą instrukcji Dodawanie portów do wyjątków Zapory Windows
__________________________________________________________________________________________________________
Masz pytania?
Dołącz do nas! Zaloguj się do Społeczności Klientów Symfonii i zadaj pytanie w obszarze wiedzy, który Cię interesuje.
Aby zalogować się do naszej społeczność, potrzebujesz konta w Symfonii ID.
Jeśli jeszcze go nie masz – skorzystaj z instrukcji
__________________________________________________________________________________________________________