Problem:
Podczas próby wejścia do pulpitu nieobecności program zamyka się błędem generalnym. Problem występuje przy próbie przejścia do pulpitu nieobecności u niektórych pracowników lub grupy pracowników, w której ten pracownik występuje.
Po wywołaniu Pulpitu nieobecności wyświetla się informacja: Trwa przygotowywanie danych i po chwili program się zamyka.
Przyczyna:
Problem występuje u pracowników, którzy mają nietypowo wprowadzaną inicjalizację kalendarza: najpierw wprowadzona inicjalizacja dniem wolnym od pracy bez daty końcowej. Następnie na taki kalendarz wprowadzana jest inicjalizacja z godzinami pracy. Jeżeli w danym miesiącu w ostatnim dniu roboczym jest wprowadzony urlop wypoczynkowy, a nie ma jeszcze żadnej inicjalizacji z godzinami pracy, to przy próbie wejścia do pulpitu nieobecności program się zamyka.
Rozwiązanie:
Plik: Sage.PL.Payroll.Common.ApplicationLayer.dll
Sposób wczytania rozwiązania:
Przed wczytaniem rozwiązania proszę wykonać kopię bezpieczeństwa.
Przy zamkniętej aplikacji Symfonia ERP Kadry i Płace 2021.2.a skopiować plik Sage.PL.Payroll.Common.ApplicationLayer.dll do katalogu z instalacją programu na wszystkich stanowiskach. Podczas kopiowania pliku należy zastąpić istniejący plik.
Uwaga!
Z uwagi na zabezpieczenia systemowe czasami po pobraniu pliku z Internetu we właściwościach pliku może zostać zaznaczona opcja jako plik zewnętrzny.
Proszę sprawdzić czy w pobranym pliku o nazwie Aktualizacja_Rachunki_UCP.dll, który został dodany do katalogu z instalacją programu, we właściwościach pliku nie ma zaznaczonej opcji jako plik zewnętrzny albo Unblock.
Ten checkbox nie powinien być zaznaczony a może blokować wykonanie aktualizacji.
Może to wyglądać jak poniżej: